146 lines
5.5 KiB
Bash
146 lines
5.5 KiB
Bash
# Maintainer: George Rawlinson <grawlinson@archlinux.org>
|
|
# Contributor: malacology <guoyizhang at malacology dot net>
|
|
# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
|
|
|
|
pkgname=gotosocial
|
|
pkgver=0.17.3
|
|
pkgrel=11
|
|
pkgdesc='ActivityPub social network server written in Golang'
|
|
arch=('x86_64')
|
|
url='https://gotosocial.org'
|
|
license=('AGPL-3.0-only')
|
|
depends=('glibc')
|
|
makedepends=('git' 'go' 'yarn' 'nodejs' 'go-swagger')
|
|
options=('!lto')
|
|
backup=(
|
|
'etc/gotosocial/config.yaml'
|
|
'etc/gotosocial/template/404.tmpl'
|
|
'etc/gotosocial/template/about.tmpl'
|
|
'etc/gotosocial/template/authorize.tmpl'
|
|
'etc/gotosocial/template/confirm_email.tmpl'
|
|
'etc/gotosocial/template/confirmed_email.tmpl'
|
|
'etc/gotosocial/template/domain-blocklist.tmpl'
|
|
'etc/gotosocial/template/email_confirm.tmpl'
|
|
'etc/gotosocial/template/email_new_report.tmpl'
|
|
'etc/gotosocial/template/email_new_signup.tmpl'
|
|
'etc/gotosocial/template/email_report_closed.tmpl'
|
|
'etc/gotosocial/template/email_reset.tmpl'
|
|
'etc/gotosocial/template/email_signup_approved.tmpl'
|
|
'etc/gotosocial/template/email_signup_rejected.tmpl'
|
|
'etc/gotosocial/template/email_test.tmpl'
|
|
'etc/gotosocial/template/error.tmpl'
|
|
'etc/gotosocial/template/finalize.tmpl'
|
|
'etc/gotosocial/template/index.tmpl'
|
|
'etc/gotosocial/template/index_apps.tmpl'
|
|
'etc/gotosocial/template/index_register.tmpl'
|
|
'etc/gotosocial/template/index_what_is_this.tmpl'
|
|
'etc/gotosocial/template/oob.tmpl'
|
|
'etc/gotosocial/template/page.tmpl'
|
|
'etc/gotosocial/template/page_footer.tmpl'
|
|
'etc/gotosocial/template/page_header.tmpl'
|
|
'etc/gotosocial/template/page_ogmeta.tmpl'
|
|
'etc/gotosocial/template/page_stylesheets.tmpl'
|
|
'etc/gotosocial/template/profile.tmpl'
|
|
'etc/gotosocial/template/profile_fields.tmpl'
|
|
'etc/gotosocial/template/settings.tmpl'
|
|
'etc/gotosocial/template/sign-in.tmpl'
|
|
'etc/gotosocial/template/sign-up.tmpl'
|
|
'etc/gotosocial/template/signed-up.tmpl'
|
|
'etc/gotosocial/template/status.tmpl'
|
|
'etc/gotosocial/template/status_attachments.tmpl'
|
|
'etc/gotosocial/template/status_attributes.tmpl'
|
|
'etc/gotosocial/template/status_header.tmpl'
|
|
'etc/gotosocial/template/status_info.tmpl'
|
|
'etc/gotosocial/template/status_poll.tmpl'
|
|
'etc/gotosocial/template/tag.tmpl'
|
|
'etc/gotosocial/template/thread.tmpl'
|
|
)
|
|
source=(
|
|
"$pkgname::git+https://github.com/superseriousbusiness/gotosocial#tag=v$pkgver"
|
|
'sysusers.conf'
|
|
'tmpfiles.conf'
|
|
'use-fhs-directories.patch'
|
|
'support-unix-sockets.patch'
|
|
)
|
|
sha512sums=('029c59888f75f217446a06309db075556a4dfdeafd9b731fa7e0b7a437fca3f030e10029b0f774f04695b16bd7c0504e28e964e8ed280bea1bdce3ec007c67d7'
|
|
'68890539a1285a819d5a2cd755aeabd59a9872926d9c32e5d54faaf2771414f006e568f2f813f3c6fcd9dbeda7b6e57c924d7490521880cb65632e02fabcbd63'
|
|
'b89fad3073e140f17167515b38942e5b5e2bc2aee03c484e1bb7cf6444f86cb1e2a13a60b101e04d22633d348be073ca26cd309da4746e5062c12b4f3ce4b38a'
|
|
'913a5209487aba06bf1d8ac7c02506a05d01a8e12f172666c84bf6870d6237640d4745617b0f07ea8c9dcf665f4e0d24a0aabef31611909f7e9384ed6e7b7e77'
|
|
'0dabf00f568ea041284789023eccea97863ce6ddb195c94318cf0a932b7c35da9beab9c78eb1c1b9ffa196685fb44eb98e0ad94da96b351644c856d9ac86e24f')
|
|
b2sums=('579a4e16f97aef42dc1952873f5a443476d34d8724c1c401ae6ae6acb1fb0e109ad5045da3597475e8c0816afdb276dc8820f40f6cb82e2426a61a2efceffa8b'
|
|
'0a5be7ac18af882c0c89d8e930eb76c2e60bc2c1d5a375ab04e987c7de9a7a3175319c4e5fbc818261141daf5f70d583aebcc2dc197fe3a88047fbfe488ccb94'
|
|
'4f65af952441c0f54bb32049a149675e207f8993678423d369c4095c57476464614ac720eccc64d7a93a81268ad7ca41cae75ca7211bd7b78f9035f6e5341f04'
|
|
'9edd4520fb99856feb82d01935588add7f805aa180f2ed0fe169cb26576bc2e1d2c1e6ab11604d977cec6a4ad8f1d5be1413e1a366de59b89c5b869136538f8c'
|
|
'4f73bfcac274e10e0378aebbd6792bb22eb9be028f9ab2f62605d4ee29cfaa400217afe94d71b5961c54b98dab79966116462c352653d4842a55dcd214ee4625')
|
|
|
|
pkgver() {
|
|
cd "$pkgname"
|
|
|
|
git describe --tags | sed 's/^v//'
|
|
}
|
|
|
|
prepare() {
|
|
cd "$pkgname"
|
|
|
|
# create directory for build output
|
|
mkdir build
|
|
|
|
patch -p1 -i "$srcdir/support-unix-sockets.patch"
|
|
# download dependencies
|
|
export GOPATH="${srcdir}"
|
|
go mod download
|
|
|
|
# use FHS directories
|
|
patch -p1 -i "$srcdir/use-fhs-directories.patch"
|
|
}
|
|
|
|
build() {
|
|
cd "$pkgname"
|
|
|
|
# set Go flags
|
|
export CGO_CPPFLAGS="${CPPFLAGS}"
|
|
export CGO_CFLAGS="${CFLAGS}"
|
|
export CGO_CXXFLAGS="${CXXFLAGS}"
|
|
export GOPATH="${srcdir}"
|
|
|
|
# generate up-to-date swagger.yaml
|
|
swagger generate spec --scan-models --exclude-deps -o web/assets/swagger.yaml
|
|
sed -e "s/REPLACE_ME/$pkgver/" -i web/assets/swagger.yaml
|
|
|
|
go build -v \
|
|
-buildmode=pie \
|
|
-mod=readonly \
|
|
-modcacherw \
|
|
-ldflags "-compressdwarf=false \
|
|
-linkmode external \
|
|
-extldflags '${LDFLAGS}' \
|
|
-X main.Version=$pkgver" \
|
|
-o build \
|
|
./cmd/...
|
|
|
|
# generate web assets
|
|
yarn --cwd ./web/source install --frozen-lockfile
|
|
yarn --cwd ./web/source ts-patch install
|
|
yarn --cwd ./web/source build
|
|
}
|
|
|
|
package() {
|
|
# systemd integration
|
|
install -vDm644 sysusers.conf "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
|
|
install -vDm644 tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
|
|
install -vDm644 "$pkgname/example/$pkgname.service" -t "$pkgdir/usr/lib/systemd/system"
|
|
|
|
cd "$pkgname"
|
|
|
|
# binary
|
|
install -vDm755 -t "$pkgdir/usr/bin" "build/$pkgname"
|
|
|
|
# configuration
|
|
install -vDm640 -t "$pkgdir/etc/$pkgname" example/config.yaml
|
|
|
|
# web frontend
|
|
install -vd "$pkgdir/usr/share/$pkgname"
|
|
cp -vr web/assets/* "$pkgdir/usr/share/$pkgname"
|
|
cp -vr web/template "$pkgdir/etc/$pkgname"
|
|
}
|